Found 2 bugs which prevents me of recording

JtheDudeC
Posts: 9
Joined: 05 May 2017, 20:01

Found 2 bugs which prevents me of recording

Postby JtheDudeC » 05 May 2017, 20:11

Hey there,
first of all, I love the visual expierence of the mod.
Using the 2013_Final version.

However, I encountered 2 bugs.

1.) When Gordon Freeman should be teleported to Black Mesa East, Lamarr (Kleiner's pet headcrab) is falling through a vent shaft.
Well, she gets stuck for a short time, after the cover of the shaft is falling down.
Afterwards she justs sits there on the pipe, without doing anything, while she actually should jump into the players face, while Gordon gets teleported as that's how she gets to the beach in the following scene.
Is there any way to fix this? Have I installed it wrong?

2.) When meeting Brother Grigori at the church you need to follow him over a graveyard. At the way to the graveyard there are a few fences to pass.
Well, Grigori just stops at a specific position and teleports to the next area, when the player reaches it.
Is this another issue on my side or is it really intended?

If that's intended, is there any way to easily get back to the default behavior?

I really would like to record a playthrough with this mod, but those are immersion killers :(
I don't mind a few weird differences in the maps (on the canal route - the riddle with the sealed stuff under water which needs to get freed to be able to continue is shortened; there is a new ladder in at the place where you need to defeat the boss helicopter. What's the purpose?) but the default animations still should work.

PS:
Just fixed the problem with Lamarr.
I restored the original models (from the original HL2 with GCFShape) and it worked again.
The problem is that normal headcrabs now look pretty original (low rez) again.
I've searched for a new skin on gamebanana and found simple materials\models (which isn't the same as the actual "models" that get into the models head folder).
I have attached that new skin without testing the Lamarr sequence, but as it just changes the texture and not the actual model, it should work.
Hopefully, Grigori is fixable in a similar way.

JtheDudeC
Posts: 9
Joined: 05 May 2017, 20:01

Re: Found 2 bugs which prevents me of recording

Postby JtheDudeC » 06 May 2017, 00:51

Ok, just played to Grigori again.
It seems this is a deeper problem, as it wasn't fixable, just by replacing the model.

Guess there is a script in the map, which does this?

I fear that's not fixable for me. :(
Anyone else expierenced that problem or even knows a fix?

PS:
I was able to lure him a bit further from the point the stands still, by running back to the church, which will him start to move again, following Gordon.
Quickly run back into the hallway with the curve, but stop before you get too close to the fence.
Grigori will follow and stand still again, even being very near at the fence this time (not back where you need to go round a bend).
But as soon as you walk closer to the fence he still will get teleported to the other side.
Which is a bit awkward as the original definitely had an animation there about Grigori climbing over the fence. :(

PPS:
Just was able to get with him to the fence right after his speech, when Grigori starts to run towards the hallway.
You need to get Gordon in front of him and he will follow Gordon even down the curve close to the fence.
But there is always that point, where Grigori teleports.

I actually only found videos about CM2013 and that sequence where that respective part is cut out. :(

It seem in V11 it still worked:
https://youtu.be/01H7hHVsxmk?t=753

Well, I think this one uses CM2013 either and it works for him... :o
https://youtu.be/V8Rdd8gOq0k?t=407
Guess I need to record the issue on my own then...

PPPS:
This is how I see it:
https://www.youtube.com/watch?v=wAP7r1ycXsU

https://www.youtube.com/watch?v=qUG77EkWvD4

JtheDudeC
Posts: 9
Joined: 05 May 2017, 20:01

Re: Found 2 bugs which prevents me of recording

Postby JtheDudeC » 06 May 2017, 16:56

Well, I played on to try the rest of the mod out.

I really like the idea of changing the Highway 17 maps to night time.
But now I am directly before a tunnel with a loading area.
Everytime I get to the point where the game says "Loading..." I get back to the main menu.
It's tunnel where you get to the house at the railway bridge afterwards. There you need to climb up to a control point at the bridge to open up a path to the rail road for your buggy.
Hopefully that's elaborated enough.

I switched to the regular maps (Highway 17 at day time) and I can get over that section (with AI disabled as of the map change of course. :().
So leaving that option out seems to fix the problem, but it's still a pitty as I really liked the maps at night. :(

Anyone else has that problem?
Otherwise I probably will need to play it without the night time option.

PS:
Just reinstalled and tried again.
I can confirm that the night maps simply don't work. To be fair: At least until this point, which is still a no-go, as of not being able to continue the game.
As soon as I switch to the day time maps, I can get over that point (even with the same savegame), without getting sent back to the main menu.
So the option to switch Highway 17 to night is out of use, as of running into a plot stopper.
Just don't use it, since it's not possible to switch between the maps on the fly as that will cause issues with the graphs and AI.

JtheDudeC
Posts: 9
Joined: 05 May 2017, 20:01

Re: Found 2 bugs which prevents me of recording

Postby JtheDudeC » 07 May 2017, 18:55

Just played through.
Beside of a few CTDs (especially when fighting against the Striders in the complex with the destroyed buildings), there weren't any further issues.

Those are the models I used:
https://www.dropbox.com/s/kknylxz8bzq9zvh/CustomModPack-CM2013-ready.rar?dl=0
Please read the README if you want to use them either.
They're configured to work "on-the-fly", as soon as you copied them into the correct directory and overwrote existing files.
Especially the combine have now a pretty unified look (especially the black elite).

Dr. Breen looks a bit stoned at the end, but if someone wants he can of course overwrite any of those skins afterwards by changing specific ones with the Character Pimper.
Or download totally different ones from the respective sites I mentioned in the Readme, like I did.

The mod is good.
I like the overall atmosphere.
There are a few issues about teleporting chars, as reported but those are the only immersion killers and issues which only occur on specific points.

JtheDudeC
Posts: 9
Joined: 05 May 2017, 20:01

Re: Found 2 bugs which prevents me of recording

Postby JtheDudeC » 08 May 2017, 11:52

EDIT: The package is now fixed.

Current features:
- Original Strider sound recovered
- Original Headcrab_Classic sound recovered
- New crossbow "fly" sound, as the current one sounded somehow "organic", like a word
- New barney uniform and face (models and textures)
- Lamarr had a problem with the animation during the teleporting sequence (she should jump directly into Gordons face). Fixed by original models.
- New Nova Prospect prison guard texture
- New combine soldier and eltie texture
- New metro police texture (different to Barney's outfit. Let's say he has a special grade, therefore wearing something different and not so generic).
- Classic_Zombie has original model but new textures (no more weird grey hands)
- All weapons have high def texture (when playing without the mod weapons), but still look pretty original. (Except the RPG, as that is now olive green like military color)
- New textures for Alyx, Breen, Eli, Kleiner, Grigori (only face), Mossman, Odessa. All of them are close to the original.


Return to “Cinematic Mod 2013”

Who is online

Users browsing this forum: No registered users and 4 guests